Differenze tra le versioni di "CodeIgniter"

m
Corretto link interrotto
m (Incipit)
m (Corretto link interrotto)
Grazie alle sue caratteristiche può essere installato facilmente in quasi tutti i sistemi di hosting e con varie versioni di [[PHP]]. La versione 3 richiede come minimo [[PHP]] versione 5.3.7 (5.6 consigliata)<ref>{{Cita web|url=https://codeigniter.com/user_guide/general/requirements.html|titolo=Server Requirements — CodeIgniter 3.1.10 documentation|sito=codeigniter.com|accesso=2019-07-11|urlarchivio=https://web.archive.org/web/20190711002349/https://codeigniter.com/user_guide/general/requirements.html|dataarchivio=11 luglio 2019|urlmorto=sì}}</ref>, mentre la nuova versione 4, attualmente in versione beta, richiederà come minimo la versione 7.2 (o successive)<ref>{{Cita web|url=https://codeigniter4.github.io/CodeIgniter4/intro/requirements.html|titolo=Server Requirements — CodeIgniter4 4.0.0-beta.3 documentation|sito=codeigniter4.github.io|lingua=EN|accesso=2019-07-23}}</ref>.
 
CodeIgniter può interfacciare, per mezzo di driver, vari diffusi [[Base di dati|database]]<ref>{{Cita web|url=https://www.codeigniter.com/user_guide/generalintro/requirements.html?highlight=requirements|titolo=Server Requirements — CodeIgniter 3.1.10 documentation|sito=www.codeigniter.com|accesso=2019-07-11|urlmorto=sì}}</ref>:
 
* [[MySQL]] v.5.1+ con driver mysqli e pdo
252

contributi